编译运行EasyAR的Unity样例

这篇文章介绍如何运行EasyAR unity样例。

*如果你需要使用EasyAR.unitypackage配置EasyAR,请阅读这篇文章

Pre-Requirements

Unity 4.6或更新版本

(如果要发布Android应用)Android SDK with Build Tools 至少需要版本20.0.0

(如果要发布iOS应用)IPhone或IPad或其它真实Apple设备(EasyAR不支持在虚拟机上运行)

打开样例

首先你需要打开unity样例工程并打开样例中的场景。

Unity 4 如下图所示,

而Unity 5 如下,

使用Unity 5打开工程之后,需要按照Unity的说明升级工程。升级之后就可以正常使用,配置和Unity 4相同。

输入Key

找到 ‘EasyAR’ object 并在inspector中输入‘Key’。如果key是非法的,程序初始化将会失败,可能显示黑屏。

按照下面的说明在TextArea 中填入Key。

就是这么简单!现在就可以在包括Windows/Mac/Android/iOS所有平台上运行Unity 样例了。

XCode 配置

*如果你在使用最新的Unity版本,Unity会自动完成这个步骤。

如果你在生成iOS app,在Unity打包生成Xcode工程之后,需要多一步设置。

XCode 6.x: 添加 “libc++.dylib” 到链接选项中

XCode 7.x: 添加 “libc++.tbd” 到链接选项中。并设置 “Enable Bitcode” 为“NO”。