Inicio rápido del desarrollo de EasyAR Mega Unity con ejemplos
Este tutorial presenta como configurar y ejecutar el ejemplo de EasyAR Mega Unity para empezar rapidamente con el desarrollo de EasyAR Mega.
Antes de empezar
Antes de leer este articulo, asegurese de haber completado:
- Tener una biblioteca de localizacion en la nube valida.
- Instalar Unity (2021.3.30 LTS o superior). Se recomienda usar la version mas reciente de Unity 2022.3 o Unity 6.3.
- Importar los paquetes
com.easyar.sense-**.tgzycom.easyar.mega-**.tgzsegun el metodo de habilitar Mega.
Nota
Este tutorial solo se aplica a versiones del plugin Unity >= 4003. Si por casualidad descargo una version antigua pero esta leyendo la documentacion de inicio, primero debe descargar la version mas reciente del plugin.
Uso del ejemplo (seis pasos)
A continuacion se presentan en seis pasos como configurar y ejecutar el ejemplo principal de EasyAR Mega, MegaBlock_Basic.
Paso uno: importar el ejemplo
Nota
Si importo todos los ejemplos mediante **All Samples**, debe omitir este paso.
- Use el menu
Window>Package Managerpara abrir Package Manager, seleccioneEasyAR Sense Unity Pluginy expanda todos los ejemplos en Samples a la derecha. - Seleccione un ejemplo, como
MegaBlock_Basic, y haga clic en Import.

Nota
- Este tutorial no se puede aplicar directamente a dispositivos headset, pero antes de desarrollar para headset debe usar desarrollo en telefono para conocer el flujo.
- Si ya habia importado ejemplos de una version antigua del SDK, despues de actualizar el SDK debe eliminar los ejemplos antiguos y volver a importarlos.
Paso dos: configurar SDK y servicio de localizacion en la nube Mega
En la barra de menus, seleccione
EasyAR>Sense>Configuration;

Pegue su License Key en el panel Project Settings abierto;

Consejo
EasyAR Sense License se puede crear desde EasyAR Developer Center. La primera vez puede crearla siguiendo estos pasos:

- Cree
EasyAR Sense 4.x Personal Edition - Para mapa espacial disperso, seleccione
No - El nombre de la aplicacion puede ser cualquiera; rellene Bundle ID y Package Name con
com.mycompany.myproject - Seleccione la License que acaba de crear y, al entrar, haga clic en el boton de copiar de la derecha

Nota
Bundle ID y Package Name se pueden cambiar posteriormente, pero el numero de cambios es limitado. Si ya tiene un nombre de paquete de aplicacion claro, tambien puede rellenar su propio nombre.
No hay limite en la cantidad de ediciones personales que puede crear. Otros tipos pueden crearse segun sea necesario para uso formal.
- Cree
Compruebe y active la opcion
Mega > Mega Block/Landmark supporten el panel Project Settings;

Configure la informacion de su biblioteca de localizacion en la nube Mega en el elemento
Mega Blockdel panel Project Settings;

Consejo
La configuracion de la biblioteca de localizacion en la nube Mega se puede obtener desde EasyAR Developer Center.

Asegurese de que suAPI Keytenga permisos deMega BlockySpatialMap. Si no los tiene, debe modificarla o crearla de nuevo.

Si no encuentra la biblioteca de localizacion, primero debe configurar correctamente la biblioteca de localizacion y volver a comprobar que la biblioteca de localizacion en la nube es valida.
Paso tres: configurar Mega Block
Configure Mega Block;
Seleccione
Mega Blocky rellene el ID y el Name del Block.

Consejo
Block ID y Name se pueden obtener desde la biblioteca de localizacion correspondiente en EasyAR Developer Center.

Si no hay datos de Block en la biblioteca de localizacion, debe agregar el Block necesario a la biblioteca de localizacion y volver a comprobar que la biblioteca de localizacion en la nube es valida.
Paso cuatro: colocar contenido 3D
Seleccione
Mega Blocky cree la herramienta de editor;
Compruebe la informacion del servicio y conecte el servicio;

Consejo
Si no hay otros cambios, la informacion del servicio debe ser igual a la rellenada en Project Settings.
Despues de conectar correctamente el servicio, debe ver la hora de actualizacion y la interfaz de control de datos de editor del Block.

Cargue los datos de editor del Block;
Haga clic en el primer selector bajo los datos del Block. Esto iniciara el proceso de carga de los datos de editor del Block. Despues de cargar, podra ver el mesh del Block actual en la ventana Scene:

Consejo
El Block mesh cambia de LOD segun la posicion de la camara; debe mantenerse la conexion de red.
Coloque contenido 3D
En este momento, puede colocar objetos 3D tomando como referencia el Block mesh.

Nota
- Los objetos 3D deben colocarse bajo el nodo Block para asegurar que la posicion de renderizado del contenido virtual sea correcta durante la ejecucion.
- Los objetos 3D no pueden colocarse bajo el nodo
EasyAR.Mega.EditorTool. Este nodo solo se usa para la herramienta de editor y en algunos casos se eliminara o reconstruira automaticamente.
Paso cinco: modificar la configuracion de Player
En el menu de Unity, vaya a File > Build Settings > Player Settings, haga clic en el icono de Android y abra los ajustes correspondientes de la plataforma Android.

Modifique Package Name al Package Name mostrado en la pagina de License Key

Consejo
Por ejemplo, si al crear la License Key relleno Package Name con
com.mycompany.myproject, aqui debe rellenar Package Name concom.mycompany.myproject; de lo contrario, la ejecucion fallara.Modifique Minimum API Level a
API Level 24o superior
Modifique Scripting Backend a
IL2CPPy marqueARM64enTarget Architecture
Paso seis: compilar y ejecutar
- Agregue la escena actual a
File>Build SettingsoBuild Profiles>Scene List;

- Cambie a la plataforma de destino, como Android / iOS, y compruebe que el nombre de paquete (Bundle ID) coincida con la License Key;

- Haga clic en Build And Run.

El efecto real grabado en sitio es el siguiente:
Sobre el texto amarillo en pantalla
Durante la ejecucion, puede ver dos textos amarillos en la pantalla.
Advertencia de simulacion
Esta en la parte inferior de la pantalla:

Esta advertencia aparece porque, con la configuracion predeterminada, la aplicacion puede ejecutarse fuera del sitio. Tiene un ligero impacto en el efecto de ejecucion de la aplicacion. Si esta usandola justo en el sitio, puede modificar la configuracion de MegaTracker antes de empaquetar.
Informacion de diagnostico
Esta en la parte superior de la pantalla y se usa para conocer el estado de ejecucion y los problemas de la session. Se recomienda mantenerla visible durante el desarrollo y las pruebas:

Puede consultar informacion de diagnostico en la escena para conocer rapidamente como configurar y usar esta informacion de diagnostico.
Siguiente paso: de principiante a experto
Enhorabuena. Con los pasos anteriores, ha ejecutado correctamente el ejemplo principal de EasyAR Mega en 10 minutos y ha experimentado personalmente la localizacion espacial y la superposicion de contenido AR.
Ahora ya domina lo basico. Si desea:
- Crear aplicaciones AR mas estables y eficientes
- Implementar efectos complejos como oclusion virtual-real y alineacion de contenido
- Depurar sin dispositivo o sin poder ir al sitio
Consulte las siguientes guias en profundidad. Le ayudaran a resolver problemas reales durante el desarrollo.
Desarrollo avanzado
Si desea conocer la configuracion completa del proyecto, puede consultar lo siguiente:
Si desea conocer mas sobre el uso de EasyAR, puede empezar aqui:
Al mismo tiempo, se recomienda leer lo siguiente para ayudarle a desarrollar y depurar:
Control fino de funciones Mega
Los contenidos siguientes le ayudaran a usar mejor Mega en su aplicacion:
- Uso en sitio y simulacion
- Buenas practicas de ARSession
- Agregar targets de seguimiento
- Habilitar la herramienta de editor
- Crear contenido 3D alineado con el entorno real
- Oclusion ambiental (Occlusion)
- Controlar el proceso de seguimiento
Los contenidos siguientes le ayudaran a validar funciones Mega sin ir al sitio:
Temas avanzados
Los contenidos siguientes son mas adecuados despues de tener cierta experiencia con EasyAR.
Si desea ejecutar EasyAR Mega en un headset, puede consultar:
Si desea usar AR Foundation, puede empezar aqui:



